19place
AcroPano Photo Stitcher 2.1 All the ideas and discussions
3 votes Vote

Making more systems compatable with this product

Seeing this product is clearly not compatable with all systems, it should be stated which systems are and the minimum requirements. It would be a good idea to expand the range and do a version for all systems even the early ones.

Mike Vaughan , 02.05.2011, 17:26
Idea status: under consideration

Comments

Leave a comment